Discord-Sync 1.0.0 ist da

Am 11.07. und 12.07. gibt es, aufgrund privater Ereignisse, nur eingeschränkten Support.

Vor wirklich sehr langer Zeit habe ich es angekündigt. Heute ist es so weit: Discord-Sync 1.0.0 ist da und steht ab jetzt sowohl im offiziellen Plugin-Store als auch bei mir zur Verfügung.

Was hat sich geändert?

  • CHANGE: komplette Neuentwicklung des ursprünglichen Codes
  • CHANGE: das Plugin nutzt ab jetzt die externe Discord-API
  • CHANGE: die Optionen im ACP wurden logisch gruppiert
  • CHANGE: die Redirect-Uri lautet jetzt nicht mehr ha-discord-auth, sondern nur noch discord-auth
  • FEATURE: es ist nun möglich ein WSC mit mehreren Discord-Servern synchronisieren zu lassen
  • FEATURE: das Rate-Limit der Discord-API wird nun beachtet
  • FEATURE: Discord-Sync kann nun optional im User-CP angezeigt werden, anstatt in der Verwaltung
  • FEATURE: beim Verbindung aufheben kann der Benutzer nun nicht nur gekickt werden, sondern auch einfach die Rollen auf dem Discord-Server entfernt werden
  • FEATURE: der Discord-Reverse-Cronjob funktioniert nun auch mit großen Discord-Server (mehr als 1000 Mitgliedern)
  • FEATURE: es gibt nun einen Cronjob, welcher nächtlich die Rollen und Nicknames mit Discord abgleicht
  • FEATURE: es existiert nun eine Bedingung für die automatische Benutzergruppenzuweisen (wenn Benutzer mit Discord verbunden ist)
  • FEATURE: im ACP können Benutzer nun nach Discord-ID gesucht werden
  • FEATURE: im ACP können Benutzer nun gefiltert werden nach "ist mit Discord verbunden"
  • FEATURE: OAuth2-State-Check eingebaut für mehr Sicherheit
  • FIX: Admins können sich nun nicht mehr via Discord im WSC einloggen
  • FIX: es gibt kein Problem mehr, wenn man mehrere Benutzer im ACP gleichzeitig bearbeitet
  • FIX: Banns werden nun korrekt synchronisiert und korrekt entfernt
  • FIX: das Exception-Handling wurde verbessert

Was kommt jetzt?

Jetzt werden wieder Wünsche für Discord-Sync gesammelt. Seid gerne kreativ :)

Gleichzeitig geht es jetzt weiter mit der Weiterentwicklung von anderen Plugins. Zu allererst wird 2-Stufen-Authentisierung auf einen neuen Stand gebracht. Die Entwicklung dazu geht aktuell gut voran.

Discord-Sync Gallery und Discord-Sync Calendar sind aktuell nicht mit Discord-Sync 1.0.0 kompatibel. Ich werde mich aber demnächst daran setzen diese beiden Plugins kompatibel zu machen.

Antworten 15